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Welcome! 

 

Welcome to TextSpresso! TextSpresso is the ideal tool for automating tedious text editing tasks. 

Whether you’re cleaning e-mails, preparing articles for publication, or just trying to read text 

files from another computer, TextSpresso makes the most difficult editing work as easy as a 

double click. TextSpresso comes bundled with hundreds of built-in filters for performing 

common tasks, and lets you create your own filters for whatever you need. 

 

About This Tutorial 
 

This tutorial gets you started using TextSpresso with easy to follow, step-by-step instructions. 

Before starting this tutorial you should already be familiar with common operations on your 

computer such as: 

 

� Opening folders on your hard drive and viewing their contents. 

� Launching and switching between programs. 

� Selecting menu commands. 

� Using the mouse to: click buttons; double click items; select items and text; and 

drag and drop items. 

� Cutting, copying, and pasting text. 

 

If you’re not familiar with these operations, you should review the manuals and tutorials that 

came with your computer before proceeding. 

 

Other TextSpresso Manuals 
 

This tutorial is one of three books, in PDF format, included with TextSpresso. 

 

� TextSpresso QuickStart.pdf - a brief guide designed to get new users up and 

running with TextSpresso as quickly as possible. 

� TextSpresso Tutorial.pdf - a series of hands on lessons which illustrate how to 

use TextSpresso. 

� TextSpresso Manual.pdf - a reference manual which lists and explains each 

command and feature in TextSpresso. 
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Tutorial Notes 
 

The lessons in this tutorial use files in the TextSpresso application folder. Normally after 

installation on Mac OS X this folder will be located in the Applications folder. After installation 

on Windows you can find this folder in C:\Programs\Taylor Design\TextSpresso\ 

 

Images in this manual may not exactly match what you see on your computer screen. Mac OS X 

and Windows each have unique appearance schemes, and user utilities can be used to change the 

standard appearances. This tutorial uses screen shots from both operating systems. The images 

should be similar though, and functionally equivalent. 

 

This manual was last updated for TextSpresso 3.0. Later versions of TextSpresso may introduce 

new features or user interface changes not documented in this manual. If you find any 

discrepancies, please feel free to notify Taylor Design at: help@taylor-design.com 

 

Where Do I Go From Here? 
 

If you’re completely new to TextSpresso, you’ll want to start with the very next chapter, What Is 

TextSpresso? This chapter explains and illustrates what TextSpresso can do for you. 

If you’ve already installed TextSpresso and are familiar with the general idea of text cleaning, 

you may wish to skip ahead to the chapter Filtering A File. This chapter gets you started using 

TextSpresso’s powerful built-in filters to perform common tasks. 
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What Is TextSpresso? 
 

TextSpresso is a combination text editor and cleaner. A cleaner is a program which automatically 

cleans text and data. TextSpresso uses text filters to clean text. You can think of a text filter as a 

command like any other command in your menu bar. 

 

For example, many text editors and word processors have a command called Uppercase which 

will convert all of the letters in the selected text to uppercase letters. TextSpresso has a filter 

called Uppercase which does the same thing. What’s the difference between built in commands 

and TextSpresso filters?  

 

� Filters can be created and edited by you, the end user. 

� Filters can be called by other filters to accomplish complex tasks. 

� Filters can be imported and exported. You can share filters that you’ve created 

with other users. 

 

TextSpresso In Action 
 

For example, consider the sample text below which was forwarded via e-mail:   

 

>> Fourscore and seven years ago our fathers brought forth on this contin=  

>>  ent, a new nation, conceived in Liberty, and dedicated to the  

>> proposition that all men are created equal. 

 

Even this small quote would take time and effort to clean up manually. Imagine having to fix 

pages of like this. With TextSpresso, a single filter applied to the above sample produces this: 

 

Fourscore and seven years ago our fathers brought forth on this continent, a new 

nation, conceived in Liberty, and dedicated to the proposition that all men are 

created equal. 

 

TextSpresso can save you hours of typing, editing, and fumbling through search and replace 

dialogs. With TextSpresso’s built in filters you can do all of the following and more: 

 

� Clean up garbled and encoded text from e-mails, Web pages, MIME files, and 

other Internet sources, making it easy to read and print. 

� Prepare text files for publishing on the World Wide Web. 

� Extract useful data, such as URL’s or addresses, buried in other files. 

� Prepare plain text for print publishing, implementing typesetting rules quickly and 

easily. 

� Convert text files between different platforms and encoding formats. 
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Purchasing & Registration 
 

Installation 
 

Before using TextSpresso, please make sure that your computer meets the following 

requirements. 

 

Macintosh Requirements: PowerPC G3 or higher processor; Mac OS X version 10.2 or higher. 

 

Windows Requirements: Pentium II or higher processor; Windows 98 or higher including 

Windows ME, 2000, and XP. 

 

On Windows, simply run the TextSpressoSetup.exe installer. On Mac OS X, simply double click 

the TextSpresso.dmg file. Once the file has mounted, drag and drop the TextSpresso folder into 

your Applications folder. 

 

Purchasing 
 

To purchase a license to TextSpresso, please visit the Taylor Design web site at: 

http://www.taylor-design.com/ 

 

When you purchase a TextSpresso license, an Activation Key will be sent to you. This key 

converts the TextSpresso demo you’ve already installed from demo mode to registered mode, 

giving you full access to the program. 

 

Registration 
 

To enter your Activation Key and complete your registration: 

 

1. Copy your entire registration e-mail from your e-mail program to the clipboard. You can 

generally do this by viewing the e-mail message in your e-mail program, choosing Select 

All from the Edit menu, and then selecting Copy from the Edit menu. 

2. Launch TextSpresso. The TextSpresso Registration Notice will appear. 

3. Click the Enter Key button. 

4. Click the Clipboard button to have TextSpresso automatically fill in the information 

from the registration e-mail you copied earlier, or type your Name and Activation Key 

directly, and then click OK. 
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Filtering A File 
 

This chapter shows you how to use TextSpresso to filter a file. The essential steps to filtering a 

file are: 

� Opening a text file. 

� Applying the desired filters to text in the opened file. 

� Saving the file. 

 

Filtering A File 
 

1. If it's not already running, launch TextSpresso. 

2. Select Open… from the File menu. 

3. Using the Open File dialog, select and open the file you wish to filter. For this 

lesson, open the file Lesson 1A.txt in the folder Tutorial Files. When you’ve 

opened the file, you should see a document window like the one on the next page. 

4. To filter the file, select the filter you wish to use from the Filter menu, or double 

click the filter’s name in the Filter Palette. The text in Lesson 1A.txt is typical of 

a messy e-mail. For this lesson, select Net To Text from the Filter menu. To filter 

only part of the text, select the text you wish to filter before selecting the filter to 

apply. 

5. Save the file by selecting Save from the File menu. You can also save the changes 

to a new file by selecting Save As… from the File menu. 

Notes 
 

� Normally TextSpresso will only open text files. However, you can open any file 

type by selecting the command Open Any... from the File menu. Use this option 

with caution! Editing other file types may damage their format and render them 

unreadable by other applications. 
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Filtering Text in Other Applications 
 

This chapter shows you how to use the TextSpresso Global Filter Palette and Global Filter 

Menu to filter the selected text in other applications. Using these tools you can quickly and 

easily filter text in another application as if TextSpresso’s filters were part of the application. 

 

Global Palette & Menu 
 

When TextSpresso is running you should see a small icon of a blue coffee cup in the menubar on 

Mac OS X or the taskbar on Windows, in both cases near your on screen clock. Clicking on this 

icon will display a menu of TextSpresso’s filters. This menu is available in any application. 

 

TextSpresso also offers a palette which lists its filters and will float in front of any application. 

 

To get started: 

 

1. If it's not already running, launch TextSpresso. 

2. Select the command Global Filter Palette... from the Window menu. You should see a 

palette like the one below. 
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Filtering Text in Another Application 
 

For this lesson, you need some text in another application to filter. 

 

1. Find and double click the file Lesson 2A.txt in the folder Tutorial Files. Double clicking 

this file will cause your OS to launch its default text editor (TextEdit on Mac OS; 

Notepad on Windows) and open the file Lesson 2A.txt in that editor. This will serve as 

the other application for the lesson. 

2. You should now be looking at the text of the file Lesson 2A.txt in your computer’s 

default text editor. The Global Filter Palette should still be visible on your screen, in front 

of the text editor window you’re looking at. To filter the text: 

3. Select the text you wish to filter. In most applications, you can choose Select All from the 

Edit menu to quickly select all of the text. 

4. Double click the filter you wish to apply in the Global Filter Palette. For this file double 

click the Extract URLs filter. You should see the filtered text take the place of the text 

you had selected. 

5. Try applying other filters using the Global Filter Menu as well so that you’re comfortable 

using either method. 

That’s it! With the Global Filter Palette and the Global Filter Menu you can filter text in other 

applications just as if TextSpresso was part of those applications. 

 

Notes 
 

� TextSpresso uses the clipboard when filtering in other applications, so beware that 

the clipboard contents will be replaced just as if you copied the text. Some 

applications may not allow you to copy or paste text. Global filtering will not 

work with applications that do not support copy/paste. 

� TextSpresso does not preserve styling information (font, size, bold, etc.) when 

filtering text in programs with styles, though if the text you've selected is all one 

style it should be retained. (We have been working on that feature and will be 

adding it as soon as possible.) 

� You can assign a hot key to the Global Filter Palette in the TextSpresso 

Preferences. This way whenever TextSpresso is running and you want to display 

the palette, you can simply use a hot key. You can also set TextSpresso to launch 

whenever your computer starts up and to open the Global Filter Palette when it 

launches. 
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Filtering Copied Text 
 

This chapter shows you how to use TextSpresso to filter text copied from another application. 

The technique illustrated in this chapter can be used to filter text that is not contained in a file on 

disk, but instead is contained in another application. For example, e-mails in your e-mail program 

or letters in your word processor. 

 

A faster way to accomplish this is described in the Filtering Text in Other Applications 

chapter. The essential steps to filtering copied text are: 

� Copying the text from the other application. 

� Creating a new TextSpresso document with the copied text. 

� Applying the desired filters to the text. 

� Pasting the text back into the original application. 

 

Filtering Copied Text 
 

The instructions below assume that the application containing the text to filter is already opened 

and in front. This could be an e-mail in an e-mail browser, a letter in a word processor, etc. 

For this lesson, find and double click the file Lesson 3A.txt in the folder Tutorial Files. Double 

clicking this file will cause your OS to launch its default text editor (TextEdit on Mac OS; 

Notepad on Windows) and open the file Lesson 3A.txt in that editor. This will serve as the other 

application for the lesson. With the file open in SimpleText or Notepad: 

 

1. Select the text you wish to filter. In most applications, you can also choose Select 

All from the Edit menu to quickly select all of the text. 

2. Select Copy from the Edit menu to copy the text to the clipboard. 

3. If TextSpresso is already running, make it the front application. If not, launch 

TextSpresso. 

4. Select New (Clipboard) from the File menu. After this step you should see the 

text you copied in a new document window. 

5. Apply the appropriate filter either by selecting its name in the Filter menu, or by 

double clicking its name in the Filter Palette. If you’re viewing the text from 

Lesson 3A.txt, select the Net To Text filter. 

6. When you’re finished filtering and editing the text, you may want to copy it back 

to the original application. In TextSpresso, start by selecting Select All from the 

Edit menu. 

7. Select Copy from the Edit menu. Tip: you can combine steps 6 and 7 into one 

step. Simply hold down the Option key (Mac OS) or the Alt key (Windows) and 
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click the copy icon in TextSpresso’s Toolbar. This copies the text of the front 

document to the clipboard, and closes the front document without saving.  

8. Switch back to the original application. If you’re performing this lesson, the 

original application should be TextEdit (on Mac OS) or Notepad (on Windows). 

9. Make sure that the insertion point is where you want to paste the text. If you want 

to replace the old text with the new, make sure that the old text is selected. Then 

select Paste from the Edit menu. 

 

Notes 
 

� The instructions presented in this chapter are just one way to filter the text in other 

applications. The chapters Filtering Text in Other Applications, Using Hot 

Filter, and Using Hot Edit provide instructions on using special TextSpresso 

features to more quickly filter text in other applications. 
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Choosing Filters 
 

This chapter explains the organization of TextSpresso’s filters and provides a summary of the 

most commonly used filters. The information presented below can help you find the right filters 

for your text cleaning needs. 

 

Favorites 
 

A filter can be marked as a favorite. Favorite filters are listed directly under the Filter menu and 

can be displayed in filter lists. TextSpresso ships with the most commonly used filters already 

marked as favorites for easy access to new users. Brief overviews of the favorite filters are given 

below. 

 

� Extract URL’s - extracts Internet links (e-mail address, web page links, etc.) 

from the text and places each address on its own line. 

� Mac To PC - converts a Mac text file to a PC (Windows) text. 

� Net To Text - cleans up most e-mails and converts web pages to plain text. 

� Net To Text (URL’s) - same as Net To Text, but preserves Internet links (HREF 

tags). The tags are converted to plain text addresses in parentheses. 

� PC To Mac - converts a PC (Windows) text file to a Mac text file. 

� Soft Wrap - removes line breaks (hard wrapping) from otherwise clean text. 

Useful for clean text which doesn’t fill the width of a window or a printed page. 

� Soft Wrap With Two Breaks - same as Soft Wrap only it uses two line breaks 

between each paragraph, producing an empty line between the paragraphs. 

� Sort Lines - sorts the lines/paragraphs in a text file in alphabetical order. 

� Strip E-mail Headers - strips the e-mail routing headers from e-mails. 

� Text To HTML - prepares text for web publishing or editing in an HTML editor. 

� Text To Net - prepares text for e-mail and/or message board posts so that the text 

appears identical on all computer platforms. 

� Text To Print - prepares text for commercial publishing by implementing the 

common rules of typesetting. Smart quotes, ligatures, proper spacing, etc., are all 

handled by this filter. 
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Filter Categories 
 

TextSpresso ships with hundreds of filters. The filters are arranged into functional categories to 

make it easier to find the right filter for a particular task. You can create your own categories 

when you create your own filters. The major categories are listed and explained below. 

 

Keep in mind when searching for and using filters that many of the listed filters are smaller 

components of larger MultiFilters. Normally you’ll want to find the highest level filter associated 

with the task at hand. 

 

� Calculator - filters which sum, average, or otherwise perform computations on 

selected data. 

� Case Conversion - filters which convert the case of text such as Uppercase. 

� Data Conversion - filters which convert selected data from one scale or format to 

another, such as Celsius to Fahrenheit. 

� Data Extraction - filters which extract useful data from files, such as Extract 

URLs. Also includes generic filters you can use to build extraction filters. 

� FileMaker Pro - filters which are useful when called from FileMaker Pro scripts. 

� HTML - filters which convert standard text to/from HTML. 

� Internet - filters which clean up and convert text found on the Internet. 

� Misc - general purpose filters which can be useful in a number of situations. 

� Programming - filters for manipulating source code. 

� Publishing - filters useful for typesetters, publishers, editors, and graphic 

designers. 

� Sort - filters for sorting text. 

� Templates - filters used internally by various TextSpresso menu commands. You 

can't edit these filters directly, but you can duplicate them. 

� Text Format - filters for converting among various platform standards. 

� Text List - filters useful for managing and transforming text lists. 

� Web Search - filters for searching on the selected text using various web search 

engines. 
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Using Document Histories 

 

This chapter explains TextSpresso’s Document History feature. This chapter is not set up as a 

normal tutorial chapter where you follow an example step by step. Instead it briefly explains the 

history feature and how to make use of it. 

 

In TextSpresso, whenever you edit a document the changes you make are added to that 

document’s history. Each open document has its own history of changes. The history for the front 

document is listed in the History List in the bottom right hand corner of the text editor. 

The document history allows you to undo and redo the actions you’ve performed on the 

document. This is often referred to as multi-level undo. 

 

Using Histories 

 

Using the history feature is very simple. With the document window you’re working on in front 

you can perform any of the following operations. 

 

� To move back one step in a document’s history, select the Undo command from 

the Edit menu. 

� To move forward one step in a document’s history, select the Redo command 

from the Edit menu. 

� To quickly move backward or forward any number of steps, select the step you 

wish to move to from the History submenu of the Edit menu. 

�  To quickly move backward or forward any number of steps, you may also click 

on the step you wish to move to in the History List of the text editor. 

 

It’s important to note that if you move backward a number of steps and then edit the document, 

the new action replaces the undone actions. 
 

When typing, TextSpresso will add to the document history whenever the following occurs: 

 

� You start typing in a new location. 

� You start deleting after typing or in a new location. 

� You type over or delete selected text. 
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Notes 
 

There are some preferences associated with document histories that you may wish to change. To 

get to the Application Preferences, select Preferences from the TextSpresso menu on Mac OS. 

On Windows select Preferences from the Edit menu. Then switch to the General Options 

category to edit the following preferences. 

 

� There are other applications which have History Palettes, but they may list the 

actions performed in reverse order. If you’re used to seeing the last action 

performed at the bottom of the list, check the Invert History? option in 

TextSpresso's preferences. 

� As of this tutorial’s last update, TextSpresso supported up to 100 levels of undo 

for each open document. This can be further limited in order to save memory and 

disk space using the History Limit preference. 

� Changes made to a document are stored in the TextSpresso Support folder. If you 

work on sensitive files which cannot or should not be duplicated on your hard 

disk, make sure that the Secure Delete option is checked. When you close a 

document, this will overwrite the cache files 3x with zero’s to insure that they 

cannot be recovered. 
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Using Hot Filter 

 

This chapter shows you how to use TextSpresso’s Hot Filter feature to filter the selected text in 

other applications. Hot Filter enables TextSpresso to work as if it were a built in feature of your 

other applications, and allows you to quickly filter text virtually any where on your computer. 

The essential steps to using Hot Filter are: 

 

� Selecting the text to filter in another application. 

� Using a key combination (Hot Key) and/or a screen corner (Hot Corner) to trigger 

Hot Filter. (You can set whatever key combination or screen corner you like.) 

� Selecting the filter to use from a dialog. 

 

Setting Up Hot Filter 

 

Before using Hot Filter, you have to set the Hot Filter preferences in the Preferences window. 

You only have to do this once. To do this: 

 

1. If TextSpresso is already running, make it the front application. If not, launch 

TextSpresso. 

2. Select Preferences… from the TextSpresso menu on Mac OS or the Edit menu 

on Windows. The Application Preferences window will appear. 

3. To the left of the preferences window is a list of categories. Select the Hot Filter 

category from this list. 

4. Make sure that the check box Hot Filter is checked. This turns the Hot Filter 

feature on (checked) and off (unchecked). 

5. Make sure that the check box labeled Hot Key is checked. This allows you to set 

a Hot Key to trigger Hot Filter. 

6. Using your mouse, click on the text field next to the Hot Key check box. Now 

type the key combination you would like to use to trigger Hot Filter. For this 

lesson, simply press and release the Shift key. (After this lesson you can come 

back and change it if you like.) Hint: when setting multiple keys, be sure to press 

and release them all at once. Backspace will delete the hot key. Also, note that on 

Windows there's a difference between the left and right Shift keys. 

7. Select one or more corners of your screen to serve as Hot Corners by checking 

the check boxes next to the corners. For this lesson, check the check box labeled 

Top Right. (After this lesson you can come back and change it if you like.) 

8. If you only want Hot Filter to activate when you’re both holding down the Hot 
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Key and your mouse is in the Hot Corner, check the check box labeled Require 

both key and corner? For this lesson, you want to check this box. 

9. Click the Save button to save these changes. 

 
 

In this lesson you will trigger Hot Filter by holding down the Shift key while you move your 

mouse to the top right corner of your screen. This combination was selected because it is 

unlikely to conflict with any existing application command keys. 

 

Using Hot Filter 
 

Before you can use Hot Filter, you need some text in another application to filter. For this lesson: 

 

1. Find and double click the file Lesson 4A.txt in the folder Tutorial Files. Double clicking 

this file will cause your OS to launch its default text editor (TextEdit on Mac OS; 

Notepad on Windows) and open the file Lesson 4A.txt in that editor. This will serve as 

the other application for the lesson. 

2. You should now be looking at the text of the file Lesson 4A.txt in your computer’s 

default text editor. To Hot Filter the text: 

3. Select the text you wish to filter. In most applications, you can also choose Select All 
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from the Edit menu to quickly select all of the text. 

4. While holding down the Shift key, move your mouse to the top right corner of your 

screen. 

5. You should see the Hot Filter dialog (below). Select the filter Net To Text and click the 

Filter button. Hint: You can also double click the filter Net To Text to run the filter 

without clicking the Filter button. 

 
 

That’s it! With Hot Filter you can quickly and easily filter the selected text in most applications. 

 

Notes 
 

� In a TextSpresso document, if no text is selected the whole document is filtered. 

But in other applications you must select and copy the text to be filtered. 

� The Hot Filter mechanism uses the clipboard to transfer text to/from TextSpresso. 

As a result, anything previously on the clipboard will be lost. 

� Some applications may not allow you to copy or paste text. Hot Filter will not 
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work in applications which do not support copy and paste. 

� If you decide to use a Hot Key combination for Hot Filter, you should carefully 

choose the Hot Key, especially if you leave Require both key and corner? 

unchecked. Some key combinations could interfere with existing command keys 

in other applications, and could trigger actions other than Hot Filter. 



 
21 

 

Using Hot Edit 
 

This chapter shows you how to use TextSpresso’s Hot Edit feature to quickly move the selected 

text in another application to TextSpresso for editing. Hot Edit is a shortcut for the standard 

sequence used to move text from one application to another. Normally doing this involves the 

following steps: copy the text; switch applications; create a new document; and paste the text. 

The essential steps to using Hot Edit are: 

 

� Using a key combination (Hot Key) and/or a screen corner (Hot Corner) to trigger 

Hot Edit. (You can set whatever key combination or screen corner you like.) 

 

Setting Up Hot Edit 

 

Before using Hot Edit, you have to set the Hot Edit preferences in the Preferences window. You 

only have to do this once. To do this: 

 

1. If TextSpresso is already running, make it the front application. If not, launch 

TextSpresso. 

2. Select Preferences… from the TextSpresso menu on Mac OS X or the Edit 

menu on Windows. The Application Preferences window will appear. 

3. To the left of the preferences window is a list of categories. Select the Hot Edit 

category from this list. 

4. Make sure that the check box Hot Edit is checked. This turns the Hot Edit feature 

on (checked) and off (unchecked). 

5. Make sure that the check box labeled Hot Key is checked. This allows you to set 

a Hot Key to trigger Hot Edit. 

6. Using your mouse, click on the text field next to the Hot Key check box. Now 

type the key combination you would like to use to trigger Hot Edit. For this 

lesson, simply press and release the Control key. (After this lesson you can come 

back and change it if you like.) Hint: when setting multiple keys, be sure to press 

and release them all at once. Backspace will delete the hot key. Also, note that on 

Windows there's a difference between the left and right Control keys. 

7. Select one or more corners of your screen to serve as Hot Corners by checking 

the check boxes next to the corners. For this lesson, check the check box labeled 

Top Right. (After this lesson you can come back and change it if you like.) 

8. If you only want Hot Edit to activate when you’re both holding down the Hot Key 

and your mouse is in the Hot Corner, check the check box labeled Require both 
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key and corner? For this lesson, you want to check this box. 

9. Click the Save button to save these changes. 

 
 

In this lesson you will trigger Hot Edit by holding down the Control key while you move your 

mouse to the top right corner of your screen. This combination was selected because it is 

unlikely to conflict with any existing application command keys. 

 

Using Hot Edit 
 

Before you can use Hot Edit, you need some text in another application to filter. For this lesson: 

 

1. Find and double click the file Lesson 5A.txt in the folder Tutorial Files. Double 

clicking this file will cause your OS to launch its default text editor (SimpleText 

on Mac OS; Notepad on Windows) and open the file Lesson 5A.txt in that editor. 

This will serve as the other application for the lesson. 

2. You should now be looking at the text of the file Lesson 5A.txt in your computer’s 

default text editor. To Hot Edit the text: 

3. Select the text you wish to edit. In most applications, you can also choose Select 

All from the Edit menu to quickly select all of the text. 
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4. While holding down the Control key, move your mouse to the top right corner of 

your screen. 

 

TextSpresso should immediately become the front application, and the selected text should 

appear in a new document. That’s it! With Hot Edit you can quickly and easily move text to 

TextSpresso for editing, filtering, and printing. 

 

Notes 
 

� The Hot Edit mechanism uses the clipboard to transfer text to/from TextSpresso. 

As a result, anything previously on the clipboard will be lost. 

� Some applications may not allow you to copy text. Hot Edit will not work in 

applications which do not support copying text. 

� If you decide to use a Hot Key combination for Hot Edit, you should carefully 

choose the Hot Key, especially if you leave Require both key and corner? 

unchecked. Some key combinations could interfere with existing command keys 

in other applications, and could trigger actions other than Hot Edit. 
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Writing Your First Filter 
 

This chapter gets you started writing filters by showing you how to create a simple Replace Text 

filter. By writing your own filters you can customize TextSpresso for your work and reduce 

complex text editing tasks to a simple double click. 

 

The Replace Text filter type replaces one string with another. It operates very much like the find 

and replace feature in most word processors and text editors. The difference, of course, is that if 

you need to find and replace the same text on more than one occasion, you only have to create a 

Replace Text filter once. 

 

The essential steps to creating any filter include: 

� Selecting the type of filter to create. 

� Entering the filter name and category. 

� Entering the parameters used by the filter. In the case of a Replace Text filter, 

these would be the find and the replace strings. 

� Saving and testing the filter. 

 

Getting Started 
 

In this lesson you will be using the file Lesson 6A.txt in the Tutorial Files folder. To get started: 

 

1. If TextSpresso is already running, make it the front application. If not, launch 

TextSpresso. 

2. Select Open… from the File menu. 

3. Using the Open File dialog, select and open the file you wish to filter. For this 

lesson, open the file Lesson 6A.txt in the folder Tutorial Files. 

 

You’ll notice that the name TextSpresso is misspelled as TexSpresso (no ‘t’ after the ‘x’). In this 

chapter you will write a filter to fix the mistake. 

 

Creating A New Filter 
 

To create a new filter: 

 

1. Select the menu command Edit Filters... from the Filter menu. You will see the 

TextSpresso Filter Library window. This window displays all of the filters in 

TextSpresso's library, allows you to search for filters by name and category, and 

lets you create, edit, duplicate, delete, and import/export filters. 

2. Click the New button in the TextSpresso Filter Library window. 
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3. You should see a dialog for selecting the type of filter to create. For this lesson, 

select the Replace Text filter type and click OK. 

4. You should see a filter editor. Enter the Name of your new filter before doing 

anything else. For this lesson, name the filter TexSpresso to TextSpresso. 

5. You can enter a Category for the filter. The popup menu next to the Category 

field lets you select from existing categories. To create a new category, just type 

the new category name. For this lesson, select the Misc category. 

6. If you want, you can enter up to 32K of Notes for the filter. This field is a useful 

place to describe what the filter does and also to include any special design notes. 

7. For this lesson, make sure that the Favorite? check box is checked. This marks 

the filter as a favorite, and lists it directly in the Filter menu. 

 

Building A Replace Text Filter 
 

The instructions below are specific to the Replace Text filter type. Continuing from the 

instructions above: 

 

1. Click on the Filter tab in the filter editor. You will see a new set of fields for 

editing the parameters of a Replace Text filter. (See the picture below.) 

2. Click in the Find field and then type the word TexSpresso. This is the misspelled 

word that the filter should find. 

3. Click in the Replace field and then type the word TextSpresso. This is the word 

which should replace TexSpresso. 

4. Click the Save button to save changes and close the filter editor. 

5. Close the TextSpresso Filter Library window. 

 

You should again be looking at the file you opened. Now you can fix the name error by simply 

applying your new filter. Select the filter TexSpresso to TextSpresso from the Filter menu, or 

double click the filter in the filter list. Every occurrence of the word TexSpresso should be 

replaced with the word TextSpresso. 

 

You can adapt the instructions in this lesson to create your own Replace Text filters to automate 

tasks you normally perform through a find and replace dialog. You can also begin to explore the 

many other filter types available with TextSpresso.
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Filtering Multiple Files 
 

Sometimes you have to make changes to more than one file on your hard drive. You know the 

changes that have to be made and they’re the same for all of the files. The tedious part is having 

to open, edit, and save each and every one. For situations like this TextSpresso offers a Batch 

Editor which allows you to quickly add the files to filter to a list and then filter all of them 

automatically. 

 

The essential steps to filtering a file batch are: 

� Opening a new Batch Editor. 

� Adding the files you want to process to the batch. 

� Selecting the filters to apply from the Filter menu. 

 

Preparing & Filtering a Batch 
 

1. Launch TextSpresso. 

2. Select New Batch… from the File menu. You will see a window like the one below. 

3. If you want TextSpresso to search subfolders for files when you add a folder, check the 

box Search subfolders. Otherwise TextSpresso will only add files from the top level of 

any folders you add. For this lesson you can leave this box unchecked. 

4. If you want TextSpresso to add all file types when you add a file or folder, check the box 

Add all file types. Be careful with this option. It’s easy to inadvertently add files that you 

do not want to filter, and filtering non-text files can lead to damage to those files. For this 

lesson you can leave this box unchecked. 

5. You can add individual files by clicking the Add button. You can have TextSpresso 

search a folder and add files from the folder, according to the options set above, by 

clicking the Add Folder button. You can also drag and drop files and folders from your 

desktop into the file list in the editor. For this lesson, click the Add Folder button and 

select the folder Lesson 7A Files in the Tutorial Files folder. TextSpresso will add the 

files in this folder to the batch. 

6. All of the text in the Lesson 7A Files is from the Internet. Fix this by selecting Net To 

Text (URLs) from the Filter menu. After the batch has completed, verify that it worked 

by selecting one of the files from the batch and clicking the Open button. TextSpresso 

will open that file in a new text editor. 

 

Using the Batch Editor you can quickly and easily filter groups of files. Since the Batch 

Editor is multithreaded you can process hundreds or thousands of files in the background 

while you do other work in TextSpresso. 
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Contacting Taylor Design 

 

If you have any questions, comments, or bug reports for TextSpresso or this tutorial, please feel 

free to contact us using the methods below. We would love to hear your ideas for new features, 

new filters, additional tutorial chapters, etc. 

 

E-mail 
help@taylor-design.com  

 

World Wide Web 

http://www.taylor-design.com/ 

 


